T7910 onboard RAID (SAS3008 HBA)

Hi : 

After reinstalling windows 10, The onboard SAS controller on my T7910 is not recognized by windows (See attached image), I tried to flash the controller, however, I also ended up with an error msg (see attached), any insights?

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi there,

    If you made a backup of your original firmware, I would suggest reverting back to it for now. 

    If you can't and can still boot into windows via SATA, I would suggest to download Dell's SupportAssist program which will install the correct drivers and firmware for that system.


    Like 1
    • Thank you stormson weathers 

      Unfortunately, I did not, the machine is working , i have windows installed on an m.2 hosted on the Dell Ultra speed drive PCI card , i called Dell Today and they suggested i call Broadcom support , will see how does this go 

  • I reached out to Broadcom support and they confirmed that the card is damaged (Damaged IC based on the error code) so the case closed 

    I do have an Avago MegaRaid 9361-8i PCI card, windows recognize it , however, i am not able to get to the configuration page, there is no post during  boot, i have MegaRAID Storage Manager installed, however , i can not log in (not sure which credentials are needed ) 

    Thanks in advance 

      • marstg
      • marstg
      • 8 mths ago
      • Reported - view

      Ziyad Mohamed the credentials needed when you log into your computer 

  • Have you tried using Primo Cache with additional memory???  I get good numbers with a cheap under $50 NVME disk on a Dell T3500.

Like Follow
  • 8 mths agoLast active
  • 5Replies
  • 64Views
  • 5 Following