Dell T7910 nvme boot from Cosair MP510

I have a Dell T7910 and I want to install and boot from NVME SSD.  I got a Cosiar MP510 and Supermicro AOC-SLG3-2m2 pcie card.  The bios can recognize the ssd as mass storage and I installed windows 10 on to the ssd, but it cant boot (no bootable device found).  Could you please help?

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • James  Unfortunate we have not tested those particular components to verify that they will work in a T7910.

     

    We have verified that these components will work:

     

    NVME.2 SSD Adapter *Required to Install NVME.2*

     

    WD Black 512GB M.2 2280 PCIe NVME SSD (WDS512G1X0C)

    Samsung 960 EVO Series – 500GB NVMe – M.2 Internal SSD (MZ-V6E500BW)

    Samsung 960 EVO Series – 1TB PCIe NVMe – M.2 Internal SSD (MZ-V6E1T0BW)

    Like 1
    • Jbigticket23 The following M.2 setup has worked flawlessly for me:

      Samsung 970 EVO Plus 1TB

      Dell SSD M.2 PCIe x4 Solid State Storage Adapter Card 6N9RH 80G5N JV6C8 PHR9G, on eBay for ~$100 NEW.

      Sure, it can be done cheaper, with a generic adapter, but I found them to be short of cooling features and many do not work with the Dell hardware.

      Like
  • Thanks.

    I figured out today.  I just forgot to update my bios to latest version.  After bios upgrade, the ssd can be seen as boot device.

    Like
    • James Thank you for sharing the solution.

      Like
Like Follow
  • 7 mths agoLast active
  • 4Replies
  • 189Views
  • 3 Following