Thinkstation P710 nvme with PSM2 adapter

I've bought a WD SN550 1tb nvme drive, connected it to a Orico PSM2 adapter. Tried in both the x4 and the x16 pci slots and it's not being recognised. Has anyone else had this problem? Is there something in bios I'm supposed to set?

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Lucky Phillips I've never used that particular adapter before. 


    What OS are you trying to install?


    Are you running the latest bios version?


    This is my favorite NVMe M.2 Adapter:


    SIGG NVMe M.2 Adapter

    Like 1
  • Thanks for your reply JB :) 

    It will be running freebsd. Have updated the bios to the latest version via a windows install. Have tried ubuntu (kubuntu), debian (kali), windows10 and freebsd(12.1) on it, but it doesn't recognize the drives at all from bios right through. If I have it plugged into the x16 pcie slot, the pc wont even boot. I'm assuming it's a bios setting that I'm missing. Have tried quite a few settings and been at it for days trying to work it out. The x4 slot is pcieV2 and the adapter is v3 with the 2280 m.2 in it. The x16 is V3. Is there a bios setting I'm missing or is it just not going to work?

    • Lucky Phillips I think the issue is being caused by the PCIe adapter.  Some pcie adapters are fussy about what systems they will work with.  If possible, you should try the Siig adapter that I normally use.

      Like 1
Like Follow
  • 2 yrs agoLast active
  • 3Replies
  • 32Views
  • 2 Following