PCIE expansion cards on older hardware

Separate thread started from:

https://greenpcgamers.forumbee.com/t/q6h8d19/dell-t7810-with-asus-hyper-m-2-x16-pcie-4-0-x4-expansion-card

<quote>I know this is an old post, but this info may be helpful to those who is interested in this device. The device only supports PCs that utilize PCIe bifurcation (where it can split the PCIe bus, ie: PCIe 16x will become x4/x4/x4/x4). I have tried this card on a Dell T7600, but due to the machine's lack of bifurcation only one NVMe is showing.

Bear in mind there are other options out there that do support non-bifurcation PCs, but they are costly, but I did find one called a Syba SI-PEX40142 currently going for $55 on Amazon (the company do offer M-key variants that will boot from PCIe on older systems).   However this model is a B-Key variant so performance will be halved, but at the same time still faster than SATA or SAS based mechanical drives.

Company's website is: https://www.sybausa.com/index.php?route=product/product&path=64_205&product_id=1035

I did order two today and will post here if they work when I get them.

for those interested I'm posting the amazon listing below that feature all 3 variants.

https://www.amazon.com/CREST-SI-PEX40129-Ports-Bifurcation-Controller/dp/B07HYZY7P2/ref=sr_1_1?dchild=1&keywords=syba+nvme&qid=1604001216&s=electronics&sr=1-1

 

</quote>

OK, I was finally able to try the CREST-SI-PEX40129 card and it does work with older machines such as the T7600. The expansion card does have a Micron SATA controller built-in and you can use any number of M.2 SSDs up to 5. While the Intel Optane M10 series didn't work, the generic Intel M.2 drives did. While it has an onboard controller, the expansion card did not show in the BIOS config so to confirm it cannot be used as a boot drive.

I do hope this may be of some help to those looking into getting this expansion card in the future.

10replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • stormson weathers said:
    The expansion card does have a Micron SATA controller built-in and you can use any number of M.2 SSDs up to 5.

     So just to clarify, if this device is populated by 5 SSDs, they will be seen as 5 different drives by the OS, correct?

    Like
    • erik clod-svensson That is correct.

      Like 1
    • stormson weathers 

      Question for you: I bought one of these and am having the Devil's own time with it.

      My system is Windows 8.1 (fresh install) in UEFI mode on T7610 mobo.

      Everything is up to date and working fine.

      I add this card with a blank M.2 SSD into it, and the system will not boot (claims it can't find a boot drive)

      If I go into BIOS and uncheck the box for "enable legacy option ROMS" then the entire system will not post, only getting an amber "2" on the front.

       

      Help is appreciated.

      Like
    • erik clod-svensson 

      If you are trying to boot from the M.2 it will not work. As I mentioned before that even though it has a SATA chip, the Syba SI-PEX40142 cannot boot (I realized I also given the wrong part number on my response as well). 

      Or are you having other boot issues with your current drive?

      Like
    • stormson weathers 

      I do not wish to boot from the SI-PEX4012 device, I simply wish to use it as mass storage.

      The mobo has integrated LSI SAS RAID and the 4 existing drives are plugged into it, but are not in RAID (in other words, the LSI SAS has them configured as 4 individual drives)

      My boot drive is a 256GB SSD and the system runs fine, and boots fine, as long as I don't put in the SI-PEX4012 card. Once I do, even thought the BIOS is set for UEFI mode and set to boot from the Windows boot device (the SSD) it will post and say "no boot device found"

      So I"m trying to figure out what is going on here, the BIOS is acting like it wants to boot from the SI-PEX4012 card, even though the single m.2 card in it is blank.

      Like
    • It sounds like a driver issue regarding WIn 8.1. What you can do is try booting into "Safe Mode" by pressing "Shift-F8" and let Windows boot into safe mode completely then restart normally.

      Like
    • stormson weathers 

       

      Found the issue.

      On the T7610 mobo, this add-in card is bootable and it was conflicting with my existing boot drive.

      So, by removing all drives except the add-in card, I booted up Win 8.1 on a DVD (in legacy mode in the BIOS) installed to the card, rebooted and Windows came up.

       

      So heads up to anyone with this card, either they changed the chipset on the card to make it bootable, or the T7610 mobo has enough changes to the chipset to allow this thing to be bootable.

       

      Either way, problem solved.

       

      Note: That was not fun to troubleshoot, as I was taking your word that it wasn't bootable ;-)

      I'm just giving you a hard time, I appreciate the heads on that this card existed and the help you offered.

      Cheers! 

      Like
    • erik clod-svensson Glad it worked out for you. I'm honestly quite surprised about the card booting myself. Maybe they did change the chipset by chance. Congrats on your effort!  

      Like
    •  What version of bios were you subg on the T7610, did you ave to install specific software or firmware on the PEX40129? 

      Like
Like2 Follow
  • 2 Likes
  • 1 mth agoLast active
  • 10Replies
  • 179Views
  • 3 Following