T3500 GPU crashing

Hi, I just built the following

- T3500

- w3550 CPU

- 8 gb ram (4gb x 2. I have another stick on order)

- 600w PSU

- GTX 460

 

I'm trying to upgrade to a GTX 660 Ti but it keeps crashing.  I've updated bios and GPU drivers.  Backed off GPU drivers.  Backed off bios.  Tried multiple configurations.  Device manager recognizes the GTX 660 Ti and says it's working properly.  The crashes occur wth GTA V and Deadside. I sometimes get the message "DX11 feature level 10.0 is required to run the engine.". 

Note, these games ran great on low settings on my GTX 460. 

Any ideas? 

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Was the GTX 660 Ti purchased used?

    Like
      • Brandon
      • Brandon
      • 3 wk ago
      • Reported - view

      Jbigticket23 yes it was. 

      Like
  • did you try the gpu in another system?

    Like
      • Brandon
      • Brandon
      • 3 wk ago
      • Reported - view

      Ravay unfortunately I don't have access to another system at the moment. That will be my next step. I went to two different computer shops today and they didn't have test systems either for some reason. Ugh.

      Like
      • Ravay
      • Ravay
      • 3 wk ago
      • Reported - view

      Brandon We must confirm that the gpu is good cuz there might be no issue with the system tho if you bought it off of ebay I think you can refund your money and return it 

      Like
      • Brandon
      • Brandon
      • 2 wk ago
      • Reported - view

      Ravay thanks Ravay. Unfortunately I bought it off kijiji. I bought a $90 HD7980 3gb card a few weeks ago and it didn't work either. Appeared to have water damage according to the computer shop I took it too. So far I've bought two bad cards for as much as a new one would cost lol. Live and learn I guess. Thanks for the advice. 

      Like
      • Ravay
      • Ravay
      • 2 wk ago
      • 1
      • Reported - view

      Brandon a 90$ hd79780 bruh what a scam ar rx 580 is like worth 90-100$

      Like 1
      • Brandon
      • Brandon
      • 2 wk ago
      • Reported - view

      Ravay Are you from the US? I paid $90 Canadian so like $65 USD. Hopefully that's not too bad of a deal. It's my first build and working or not I agree I overpaid for that card. I got too excited and grabbed the first deal I found. 

      Like
  • I'm using the exact desktop, 6GB  of RAM  SSD 256 GB   NVIDIA GTX 1060 6GB MSI  playing ATS/ ETS2  in DX11  I'm  an average of  67 fps

    No Crashes at all and cooling systems is good

    Like
Like Follow
  • 8 days agoLast active
  • 9Replies
  • 30Views
  • 4 Following